Wrong item images

Forum for builders of NWN material.
Post Reply
Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Wrong item images

Post by Enverex » Thu Jun 02, 2005 9:46 am

Has anyone else noticed this odd issue:

Certain images for the Misc Small items are different in the toolset than what they appear ingame. For instance, if you make something with the base item type Misc Small and give it the small banana icon, when you go ingame it will have the icon of something else (yet it looks fine in the toolset).

I've noticed a few items do this: Cookies, Single Banana, Pear...

It seems to be most of the middle (as you scroll down) icons available for Misc Small items.

Has anyone else experienced this or know a workaround?

Thanks,
Ex

Kyprioth
Clueless Prime
Posts: 10
Joined: Thu Sep 02, 2004 5:29 am

Post by Kyprioth » Fri Jun 03, 2005 8:41 pm

I'm not at my computer now, so I haven't checked it out yet, but aren't those the new CEP Icons? (Sorry, I have never really made Misc. Small Items in the Toolset) Might be something to do with that

Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Post by Enverex » Sat Jun 04, 2005 4:05 am

I was using 1.50 while having this problem. I've upgraded the server and client to 1.51 and it is still doing the same...

Just seems very odd that they appear as one icon in the toolset, and another when you actually get IG...

Kyprioth
Clueless Prime
Posts: 10
Joined: Thu Sep 02, 2004 5:29 am

Post by Kyprioth » Sat Jun 04, 2005 7:46 pm

Mmm I meant were the specific icons you tried additions from the CEP?
Try testing it with Non-CEP Icons as well. I'll check too once I have some spare time

Kyprioth

Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Post by Enverex » Sun Jun 05, 2005 5:15 am

Yes, they are the CEP ones afaik, but I can't afford to go removing the CEP haks from a 20+MB module...

Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Post by Enverex » Mon Jun 06, 2005 4:33 am

These are the icons that don't seem to work. They are half-way down the "Misc Item" category:

Image

Kyprioth
Clueless Prime
Posts: 10
Joined: Thu Sep 02, 2004 5:29 am

Post by Kyprioth » Mon Jun 06, 2005 5:18 am

Hmmm... Well, I think it might just be a CEP bug or something, but how exactly does it change the icon in-game. Does it really make much of a difference? (Or is the egg icon an apple or something?)

Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Post by Enverex » Mon Jun 06, 2005 5:31 am

Kyprioth wrote:Hmmm... Well, I think it might just be a CEP bug or something, but how exactly does it change the icon in-game. Does it really make much of a difference? (Or is the egg icon an apple or something?)
They show up as completely different icons. I.e. the cookies show up as the red chillis, the eggs show up as some type of leaf, the banana shows up as some sort of bark, etc etc.

Quite annoying as most of these icons suit the crafting system perfectly and nothing else is even close.

Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Post by Enverex » Mon Jun 06, 2005 7:10 am

Just did a Hak pak conflict analysis and it doesn't report that the icon (for example) iit_smlmisc_159 is coliding in any other paks, so it can't be the issue of something else taking priority...

Just for information, the iit_smlmisc_159 tga is located in the cep1patch.

Kyprioth
Clueless Prime
Posts: 10
Joined: Thu Sep 02, 2004 5:29 am

Post by Kyprioth » Tue Jun 07, 2005 3:28 am

OK... I've made a post about this on the Bioware NWN Forums, so you can add anything I left out to the post. If that fails, I guess the only thing to do is either not use those icons, or perform the extremely-time consuming job of making a list of what icon is what IG...

Kyprioth

Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Post by Enverex » Tue Jun 14, 2005 8:27 am

Right, I've been checking this a little more and it seems to be "Universalhakx.x" causing the problem. If you load a module and put only CEP haks in it it works fine, but the moment you add the UniversalHak to the bottom of the custom content list it starts acting funky. This seems to be some sort of weird incompatability as neither of them use these particular icons yet somehow it causes them to appear wrong.

Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Post by Enverex » Tue Jun 14, 2005 8:41 am

Ok, this may be the problem. I tried making a module purely with CEP. Sure enough, Bananas were Bananas, but then I added UniversalHak and it all went to hell. I checked for conflicts... none mentioned for these... but then I looked at the resource list...

Image

Seems the DDS files are somehow taking priority over the TGA files (and yes, the items that the DDS files are matches the wrong items that are appearing).

So, would it be possible for COPAP to remove these obscelete DDS files from the UniversalHak to allow the icons to appear properly? Alternatively I could remove them for you and send you the Hak file as then it wouldn't take you any time and I'm sure I could do it without much hassle.

?

Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Post by Enverex » Tue Jun 14, 2005 9:01 am

Ok, removed the old item image DDS' from the Hak. Does anyone on the COPAP team want me to send it to them?

Themicles
Leader: Tairis'nàdur & CoPaP Hak-Master
Posts: 886
Joined: Tue Nov 25, 2003 11:26 am
Location: Michigan
Contact:

Post by Themicles » Thu Jul 28, 2005 3:21 am

There's an inherant problem with your assumptions here.

You assume that the icons in the Universal hak aren't being used for anything.

First, they probably are.

Second, if I rename them now, any and all items already using the Universal Hak icons of those numbers will need to be remade.

At the moment, this is not worth fixing. I will reassess the situation next service update. (ie. An update not corresponding with a BioWare patch. That means there WILL be another update before 1.67.)

-Themicles
"A wise man does not dwell on his past. He learns from it, he grows from it, and then moves ahead into his future." -me

Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Post by Enverex » Thu Jul 28, 2005 4:08 am

The reason I assumed that they aren't used is because when someone makes an item in the toolset, they don't appear with those icons, the maker would have seen something else, so it seems unlikely that someone would have made something in the toolset, picked an icon and wanted it to be something else, heh.

Themicles
Leader: Tairis'nàdur & CoPaP Hak-Master
Posts: 886
Joined: Tue Nov 25, 2003 11:26 am
Location: Michigan
Contact:

Post by Themicles » Thu Jul 28, 2005 4:28 am

Enverex wrote:The reason I assumed that they aren't used is because when someone makes an item in the toolset, they don't appear with those icons, the maker would have seen something else, so it seems unlikely that someone would have made something in the toolset, picked an icon and wanted it to be something else, heh.
Are you sure you had all of the hakpaks loaded correctly and in the right order?
"A wise man does not dwell on his past. He learns from it, he grows from it, and then moves ahead into his future." -me

Enverex
Planewalker
Posts: 45
Joined: Fri Jun 04, 2004 2:41 am
Location: Worcester, UK
Contact:

Post by Enverex » Thu Jul 28, 2005 5:20 am

Themicles wrote:
Enverex wrote:The reason I assumed that they aren't used is because when someone makes an item in the toolset, they don't appear with those icons, the maker would have seen something else, so it seems unlikely that someone would have made something in the toolset, picked an icon and wanted it to be something else, heh.
Are you sure you had all of the hakpaks loaded correctly and in the right order?
Been over this many times and with different world builders and yes. It doesn't matter now anyway, no-one else seems concerned about it and it is no-longer my problem.

Post Reply