CoPaP 1.68 Update!

Frontpage news for the CoPaP project: http://www.copap.org/
Post Reply
Themicles
Leader: Tairis'nàdur & CoPaP Hak-Master
Posts: 886
Joined: Tue Nov 25, 2003 11:26 am
Location: Michigan
Contact:

CoPaP 1.68 Update!

Post by Themicles » Fri Sep 01, 2006 1:15 pm

That's right. CoPaP Hak, and Universal Hak are now 1.68 compatible! CoPaP TLK has seen some updates as well.

For Players:
Please keep in mind that the worlds you play on are not updated to 1.68 until they say so. And please be patient with their update process.

For Worlds:
Most worlds will not need to update their world specific hakpaks. As always, compare your world specific hak pak's contents with that of the latest 1.68 HotU Full 2da source, and also compare with the contents of CoPaP Hak 4.8.

Now, on to the files:
CoPaP Hak 4.8
Universal Hak 4.8
CoPaP TLK 3.6

What's in this update?

CoPaP Hak 4.8:
  • 1.68 Compatability
    Avlis PrC Fixes
    Catara Witch hunter
    Spell Additions
    Lisa's 3rd Cloaks
Universal Hak 4.8:
  • Spell Icon Additions
    Catara PrC icon additions
    Lisa's 3rd Cloaks
CoPaP TLK 3.6:
  • Avlis PrC Fixes and Additions
    Spell Additions
    Catara PrC Fixes and Additions
"A wise man does not dwell on his past. He learns from it, he grows from it, and then moves ahead into his future." -me

Silverdragonams
Planewalker
Posts: 46
Joined: Mon Sep 27, 2004 8:23 pm
Location: Hala Head DM

Post by Silverdragonams » Sat Sep 02, 2006 7:24 am

Does this include a fix for the CEP cloak icons? Last I heard CEP was still working on an official patch for this.

For anyone who doesn't know what I'm talking about, the cloak icons in the CEP hacks (not the neck pieces that look like cloaks attached to armor) do not have a 3-dimensional cloak appearance associated with them. This can cause horrible inventory bugs when a player logs into the server wearing one of these cloaks.

The CEP team has said they should have a fix for it soon.

Themicles
Leader: Tairis'nàdur & CoPaP Hak-Master
Posts: 886
Joined: Tue Nov 25, 2003 11:26 am
Location: Michigan
Contact:

Post by Themicles » Sat Sep 02, 2006 8:22 am

Silverdragonams wrote:Does this include a fix for the CEP cloak icons? Last I heard CEP was still working on an official patch for this.

For anyone who doesn't know what I'm talking about, the cloak icons in the CEP hacks (not the neck pieces that look like cloaks attached to armor) do not have a 3-dimensional cloak appearance associated with them. This can cause horrible inventory bugs when a player logs into the server wearing one of these cloaks.

The CEP team has said they should have a fix for it soon.
Cloak icons are pretty much a null point.

The new cloak system completely did away with all of BioWare's original icons. Not just the image files, but the way they are done.

The new system's icons are PLT files. And each icon goes with a matching model. This makes the CEP icons rather pointless even if turned into PLT files because none of them have matching models.

People carrying CEP icons for cloaks will be fine. It'll revert to a default BioWare icon, and default BioWare model.
"A wise man does not dwell on his past. He learns from it, he grows from it, and then moves ahead into his future." -me

Silverdragonams
Planewalker
Posts: 46
Joined: Mon Sep 27, 2004 8:23 pm
Location: Hala Head DM

Post by Silverdragonams » Sat Sep 02, 2006 11:47 am

I don't mean to be a pest, but it is my understanding that they don't always just revert to the bioware default model.

This is a quote from TheExcimer-500 on the CEP forum.
What happens without a patch is the following:
1) All cloaks retain their original inventory icons (the 2-d image)
2) The original NWN cloaks when worn have an appropriate "cloak" appear on the PC
3) The 8 CEP cloaks appear without a 3D design

All of that is fine and well, and wouldn't require a patch, except:

1) Some characters we playtested with had the "dreaded inventory bug" appear (those having CEP cloaks)
2) In the toolset there is no way to change the 3-D colors for the 3-D cloaks.

Our only concern now is for CEPv1 is to resolve the inventory bug (and to return to our work on CEPv2). As CIT & Jacen mentioned our focus must be on CEPv2, and they are right. Therefore, adapting the new cloaks is not a concern for CEPv1 as any modules created with it did not have these 3D cloaks used in them.

After considering the various options, creating various haks and playtesting through them, we have two versions of a patch developed. Tonight, the team will weigh the pros/cons of each, then follow that one up with a bit more playtesting (just to be sure).

We'll post more info as soon as we're able.

BTW: The new cloaks will work as NWN1.68 intends them to in CEPv2.
There is also this thread:
http://nwn.bioware.com/forums/viewtopic ... um=42&sp=0

Once again I dont mean to be a pain in the rear, and I won't say any more on the subject. Its just a matter of "its better to be safe than sorry".

Themicles
Leader: Tairis'nàdur & CoPaP Hak-Master
Posts: 886
Joined: Tue Nov 25, 2003 11:26 am
Location: Michigan
Contact:

Post by Themicles » Sat Sep 02, 2006 12:18 pm

We tested with pre-existing 1.67 character that had CEP cloaks.

Everything should be fine.
"A wise man does not dwell on his past. He learns from it, he grows from it, and then moves ahead into his future." -me

Post Reply